Social Media Management modules not accessible when using Safari
Incident Report for Brandwatch
Resolved
This issue has been resolved, and the platform can now be accessed from Safari as normal. Thank you for your extended patience.
Posted Jun 28, 2022 - 07:19 UTC
Investigating
We are aware of an issue currently impacting all Safari users when attempting to access the Engage, Listen and Audience modules.

No loading will occur when modules are clicked, and users will remain on their current page, with no visible error message displayed.

We are currently advising users to use another recommended browser, such as Chrome, Firefox or Microsoft Edge.

We will continue to provide updates on this issue as soon as practicable, and apologise for any inconvenience caused.
Posted Jun 28, 2022 - 00:06 UTC
This incident affected: Social Media Management (Platform (Falcon)).