Consumer Research - Backfill Issues Affecting Some Clients

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 14:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 11:14 UTC

Identified

We are currently investigating an issue impacting data backfill for a subset of clients in Brandwatch.

Our team has identified irregularities causing delays and incomplete historical data population in certain dashboards and queries.

We are actively working to resolve the problem and restore full backfill functionality as quickly as possible. We will provide further updates as soon as more information becomes available.
Posted Apr 13, 2026 - 10:41 UTC
This incident affected: Consumer Intelligence (Data Collection).