Meta: Facebook and Instagram experiencing technical difficulties
Incident Report for Brandwatch
Resolved
The incident with Meta's applications has been resolved. For further information please see their status page at https://metastatus.com/. Thank you for your patience.
Posted Mar 05, 2024 - 20:06 UTC
Monitoring
We are pleased to inform you that Meta services, including Facebook and Instagram, are now operational again. However, as Meta continues to recover from recent disruptions, we advise exercising patience as some functionalities may still be stabilising. For real-time updates on Meta's service status, please refer to Meta's official Statuspage at the following link: https://metastatus.com/
Posted Mar 05, 2024 - 18:15 UTC
Investigating
We would like to inform you that Meta (including Facebook and Instagram) are currently experiencing technical difficulties, resulting in service disruptions.

We are actively monitoring the situation and awaiting updates from Meta's technical team. We apologise for any inconvenience caused and assure you that we are closely following developments to provide you with the latest information as soon as it becomes available.

Thank you for your patience and understanding during this time.
Posted Mar 05, 2024 - 16:14 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Platform (Falcon)).