Discover Report Download Error
Incident Report for Brandwatch
Resolved
This issue has been resolved. Users will need to regenerate the Discover report for a new link, which will work as intended.
Posted Nov 08, 2024 - 19:17 UTC
Investigating
We are currently investigating an issue with Discover report download email links leading to an error page.
Posted Nov 08, 2024 - 16:13 UTC
This incident affected: Influence (Discover).