[Consumer Research] Data Downloads aren't progressing
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 12:02 UTC
Investigating
We are currently investigating an issue where some Brandwatch users are reporting Data Downloads as failing to process.

Our team is actively working to identify the root cause and implement a resolution. We are in close communication with relevant teams and will provide updates as more information becomes available.
Posted Jan 23, 2025 - 11:59 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).