Consumer Research - Dashboard Components Failing to Load

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 21:34 UTC

Monitoring

Our engineering team is seeing normal functionality return to dashboards and will monitor to ensure stability.
Posted Dec 15, 2025 - 17:08 UTC

Investigating

We are currently experiencing an issue where some dashboard components are failing to load. This may impact users’ ability to view or interact with dashboards as expected.

Our teams are actively investigating the cause and working to restore normal functionality as quickly as possible.
Posted Dec 15, 2025 - 15:33 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).