Consumer Research - Query Backfill Delays

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 18:30 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2026 - 17:32 UTC

Investigating

We are currently investigating delays affecting query backfills for Consumer Research and Listen.

Our Engineering team is actively investigating the issue.

We will provide an update as soon as more information becomes available.
Posted Jul 31, 2026 - 17:21 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).