Consumer Research - platform is not loading

Incident Report for Brandwatch

Resolved

Resolved – The issue has now been resolved, and users are able to log in to Brandwatch again.

We will continue to monitor the platform to ensure everything remains stable. Thank you for your patience while we worked to resolve this issue.
Posted Aug 04, 2026 - 15:51 UTC

Identified

We are currently investigating an issue affecting the Consumer Research platform. Some users may be unable to use the platform and may see the following error message:

"Sorry, we were unable to load your project."

Our team is actively investigating the root cause and working to restore normal service as quickly as possible.

We will provide another update as soon as more information is available.
Posted Aug 04, 2026 - 15:07 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).