Consumer Research - Query Backfill Delays

Incident Report for Brandwatch

Resolved

Thank you so much for your patience. The issue is fully resolved.
Posted May 20, 2026 - 20:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 19:00 UTC

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 17:51 UTC

Investigating

We are currently experiencing an issue where query backfills are delayed and real-time ingestion of Reddit, X, Bluesky, Tumblr, and custom uploads is affected.

Our teams are actively investigating the cause and working to restore normal functionality as quickly as possible.
Posted May 20, 2026 - 17:30 UTC
This incident affected: Consumer Intelligence (Consumer Research Application, Data Collection) and Social Media Management (Listen).