A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 11:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2026 - 11:12 UTC
Investigating
Major Incident: Platform Access Disruption
We are currently experiencing a major incident impacting multiple services across our platform. At this time, our Consumer Research, Listen, and Social Media Management products are inaccessible to users.
Our engineering teams have identified the issue and are actively working to restore service as quickly as possible. We understand the critical nature of these tools and the disruption this may cause to your workflows.
We will continue to provide updates as more information becomes available, including progress toward resolution and any relevant workarounds.
Thank you for your patience and understanding.
Posted Mar 19, 2026 - 10:52 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Platform).