Publish: Users unable to upload media files

Incident Report for Brandwatch

Resolved

The issue has been successfully resolved.
Thank you for your patience.
Posted Jul 07, 2025 - 07:44 UTC

Monitoring

A fix has been implemented. We are monitoring the system to ensure continued stability.
Thank you for your patience and understanding.
Posted Jul 07, 2025 - 06:53 UTC

Investigating

We're aware of some users experiencing issues with uploading media files into Publish. This issue has been escalated to our Product Team for further investigation and is being treated as a High Priority.

We thank you for your patience and sincerely apologise for any inconvenience and disruption this issue causes
Posted Jul 07, 2025 - 01:38 UTC
This incident affected: Social Media Management (Publish).