Publish: Posts becoming stuck in processing

Incident Report for Brandwatch

Resolved

The issue has been resolved.
Thank you for your patience.
Posted Aug 19, 2025 - 10:11 UTC

Monitoring

The issue has been completely resolved, and publishing is now operating normally.
We are continuing to monitor the system to ensure ongoing stability and smooth performance.

Thank you for your understanding.
Posted Aug 19, 2025 - 09:24 UTC

Investigating

We are aware of an issue where posts are getting stuck in the processing stage. Our engineering team is actively investigating the root cause and working on a fix.

We’ll provide updates here as soon as we have additional information.
Thank you for your patience.
Posted Aug 19, 2025 - 08:03 UTC
This incident affected: Social Media Management (Publish).