Home - Social Media Management Homepage failing to load for Safari users
Incident Report for Brandwatch
Resolved
Our issues with the Home module failing to load in Safari have now been resolved. Users still impacted are advised to reach out to our Support team via the in-app chat, or at social-support@brandwatch.com

We thank you again for your extended patience.
Posted Mar 21, 2023 - 00:19 UTC
Update
We are continuing to investigate issues with our homepage failing to load in Safari. Users are advised to continue using an alternative browser during this time.

We thank you for your patience, and apologise for the ongoing inconvenience.
Posted Mar 20, 2023 - 06:44 UTC
Investigating
We are currently aware of an issue with the Social Media Management platform homepage failing to load for Safari users. Our Development team have been notified and we are continuing to investigate.

Users are advised to use an alternative browser during this time.

We apologise for any inconvenience and will continue to provide updates as they are made available.
Posted Mar 19, 2023 - 22:56 UTC
This incident affected: Social Media Management (Platform (Falcon)).