Consumer Research - delay in backfills for new or edited Queries

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 15:32 UTC

Identified

Some users are experiencing delays in backfills for new or edited Queries in Consumer Research.

We are actively investigating and working to restore full performance.
Posted Aug 19, 2025 - 14:46 UTC
This incident affected: Consumer Intelligence (Data Collection).