[Consumer Research, Listen & Social Media Management] Platforms Inaccessible

Incident Report for Brandwatch

Resolved

We greatly appreciate your patience and understanding. We are pleased to announce that the platform access incident has been resolved.
Posted Mar 19, 2026 - 13:57 UTC

Monitoring

Access has largely been restored to the Platforms and our Engineering Team are monitoring the situation to ensure there are no further issues.

We will continue to provide updates as more information becomes available, including progress toward resolution and any relevant workarounds.

Thank you for your patience and understanding.
Posted Mar 19, 2026 - 11:33 UTC
This incident affected: Consumer Intelligence (Consumer Research Application), Influence (Influence Platform), and Social Media Management (Platform).