Query Backfills may be delayed

Incident Report for Brandwatch

Resolved

Thanks so much for your patience. The query backfill delays are now resolved.
Posted Jun 10, 2026 - 18:40 UTC

Investigating

We are currently investigating delays affecting query backfills within the platform.

At this time, we do not anticipate any data loss. Our Engineering team is actively working to identify the cause and restore normal processing as quickly as possible.

We will provide additional updates as more information becomes available.
Posted Jun 10, 2026 - 15:33 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).