Publish: Posts becoming stuck in processing

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Thank you for your patience and understanding.
Posted Aug 18, 2025 - 09:49 UTC

Monitoring

A fix has been implemented.
We are actively monitoring the Publish module to ensure it is fully operational.
Thank you for your patience.
Posted Aug 18, 2025 - 08:38 UTC

Investigating

We are currently experiencing issues with posts becoming stuck in processing across Facebook, Instagram, Twitter/X and LinkedIn.

Our Technical team has been notified and we are treating this as a priority, and will provide all updates as soon as they are available.

We thank you for your patience and apologise for any frustration caused.
Posted Aug 18, 2025 - 07:15 UTC
This incident affected: Social Media Management (Publish).