Consumer Research - Social Panels

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 18:39 UTC

Identified

We are currently experiencing an issue affecting Social Panels, which may result in degraded performance or limited availability for some users.

Our engineering team has identified the cause and is actively working on a resolution.
Posted Nov 18, 2025 - 18:32 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).