[Consumer Research / Listen] Data Ingestion Delays

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 15:51 UTC

Investigating

We are aware of some delays with data ingestion within Consumer Research and Listen.

Our Engineering Team are working to clear the backlog as soon as possible.

Further updates will follow as soon as additional information becomes available.
Posted Sep 21, 2026 - 12:55 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Listen).