Consumer Research - Query Backfill Delays

Incident Report for Brandwatch

Monitoring

A fix has been implemented by our Engineering Team, and we are currently monitoring the results. We will provide an update once the issue has been completely resolved.
Posted Aug 18, 2026 - 02:03 UTC

Investigating

We're currently experiencing a delay with query backfills, and our Engineering team is investigating the cause.
Posted Aug 17, 2026 - 22:28 UTC
This incident affects: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).