Query Backfill Slowdown

Incident Report for Brandwatch

Resolved

This incident has now been resolved.
Posted Sep 05, 2025 - 12:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2025 - 07:22 UTC

Identified

We're currently experiencing delays in query processing. This is causing a backlog of backfilling queries and some tasks are taking significantly longer to complete.

Our team is actively investigating and working on a fix. Affected queries will eventually retry and complete, but performance is degraded at this time.
Posted Sep 03, 2025 - 19:00 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).