Consumer Reseaerch - Query Backfill Delays

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted May 18, 2026 - 22:46 UTC

Monitoring

Our Engineering team has implemented a fix for this issue and are monitoring the progress as the query backlog is cleared. Clients may continue to experience delays in query backfills until the backlog is fully clear.
Posted May 18, 2026 - 21:46 UTC

Investigating

We are currently experiencing an issue where query backfills are delayed. This may impact users attempting to process or access historical data.

Our teams are actively investigating the cause and working to restore normal functionality as quickly as possible.
Posted May 18, 2026 - 21:13 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).