[Consumer Research] Platform is currently unavailable

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 12:20 UTC

Investigating

We are currently aware of an issue where Consumer Research is unavailable. Our Engineering team is actively investigating and working to restore access as quickly as possible. Further updates will be provided as we learn more.

Thank you for your patience.
Posted Sep 08, 2025 - 12:11 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).