Listen - Module Not Loading

Incident Report for Brandwatch

Resolved

The issue with the Listen module not loading has been resolved.

Thank you for your patience.
Posted Feb 20, 2026 - 21:04 UTC

Investigating

We are currently experiencing an issue where the Listen module is not loading as expected.

Our development team is investigating and actively working on a resolution.

We appreciate your patience and will share updates as progress is made.
Posted Feb 20, 2026 - 20:10 UTC
This incident affected: Social Media Management (Listen).