Settings: "This page is down" error when connecting Twitter/X channels
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 12:01 UTC
Investigating
Twitter/X appears to currently be experiencing an outage in its API, and this is preventing users from connecting channels for this network via our platform.

On redirection to Twitter/X from our channel management settings, users are shown a "this page is down" error screen, with no option to proceed.

We will continue to monitor the progress of this issue, and provide all updates as soon as they are available. We thank you for your patience and understanding.
Posted Mar 20, 2024 - 00:47 UTC
This incident affected: Social Media Management (Platform (Falcon)).