Publish - Facebook and Instagram posts failing
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 14:44 UTC
Investigating
We are currently investigating this issue.
Posted Sep 18, 2024 - 14:03 UTC
This incident affected: Social Media Management (Publish).