Consumer Research - Mention List Component

Incident Report for Brandwatch

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 18:40 UTC

Investigating

The Mention List component currently has degraded performance. Users may experience mentions not loading, filtering and search issues, and refreshing not performing as expected.

While our Engineers work toward a resolution, we recommend utilizing other components, as a number of functionalities are present in other components.
Posted Jun 10, 2026 - 16:23 UTC
This incident affects: Consumer Intelligence (Consumer Research Application).