Delay in X/Twitter data

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 21:19 UTC

Monitoring

We are monitoring latency, which is resolving.
We also noted that Facebook and Instagram mentions may be delayed ingesting. This is resolving as well. We will provide another update when the delays are fully resolved.
Posted Jan 26, 2026 - 16:24 UTC

Investigating

We are aware of an issue causing delays in the ingestion of X (Twitter) mentions. As a result, some mentions may not be visible in Brandwatch in real time and could appear later than expected. Our engineers are actively investigating the cause, and we’ll share updates as progress is made.
Posted Jan 26, 2026 - 09:48 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).