Engage - Loading Errors

Incident Report for Brandwatch

Monitoring

A fix has been implemented and we are monitoring results in the Engage module.

Thank you for your patience.
Posted Aug 21, 2025 - 23:20 UTC

Investigating

We are aware of an issue with loading conversations and user profiles, as well as issues creating cases in Engage.

The development team is working on a fix with high priority.

Please continue to check back for updates. Thank you for your patience.
Posted Aug 21, 2025 - 20:52 UTC
This incident affects: Social Media Management (Engage).