The Incident has been fully resolved. The channel connection process should now be working as expected and is fully operational. Thank you for your patience.
Posted Aug 18, 2025 - 10:03 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2025 - 14:57 UTC
Monitoring
Meta’s API has returned to operational status.
Our development team is actively validating end-to-end functionality and monitoring connections.
Thank you for your patience. We will update once all systems are confirmed functioning.
Posted Aug 14, 2025 - 21:53 UTC
Update
We are continuing to investigate this issue.
Posted Aug 14, 2025 - 12:38 UTC
Update
We are continuing to investigate this issue.
Posted Aug 14, 2025 - 12:27 UTC
Investigating
We are currently experiencing disruptions with Facebook and Instagram channel connections. Preliminary findings indicate that the issue originates from Meta’s systems.
Our team is actively monitoring the situation and will provide further updates as they become available. We apologise for any inconvenience this may cause.
Posted Aug 14, 2025 - 11:12 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Platform, Publish, Engage, Advertise, Measure, Benchmark, Listen).