Labels Cannot Be Added to Content in Engage

Incident Report for Brandwatch

Identified

Our Engineering team has identified the root cause of the issue affecting publishing to LinkedIn and has developed a fix.


The team is now completing the final steps necessary before releasing the fix. In the meantime, customers may still experience publishing failures.


We will share an update once the fix has been deployed and we have confirmed that the issue is resolved.


We apologise for the ongoing disruption and appreciate your patience.
Posted Sep 18, 2026 - 12:00 UTC

Investigating

We are experiencing an issue where we are unable to add labels to content in Engage.
Posted Sep 18, 2026 - 09:46 UTC
This incident affects: Social Media Management (Engage).