The issue affecting Measure dashboards has now been fully resolved.
Our teams identified and addressed the underlying issue, and dashboard functionality has since been restored. Following additional monitoring and validation, we can confirm that services are operating as expected and users should now be able to access and load their dashboards normally.
We will continue to monitor the service to ensure ongoing stability.
We apologise for the disruption this may have caused and thank you for your patience while our teams worked to resolve the issue.
Posted Sep 08, 2026 - 13:48 UTC
Investigating
We are currently investigating an issue affecting Measure dashboards, where some users may be unable to load or access their dashboards.
Our teams are actively investigating the cause and working to restore normal functionality as quickly as possible.
We will provide further updates as more information becomes available.
Posted Sep 08, 2026 - 10:34 UTC
This incident affected: Social Media Management (Measure).