Support Channels Down

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 21:22 UTC

Monitoring

Our chat and email support software provider has implemented a fix and is monitoring the situation to ensure it is fully resolved. Support inquires are in progress again and we'll provide another update once our provider has confirmed this is fully resolved.
Posted Jan 09, 2026 - 21:20 UTC

Investigating

Our chat and email support software provider is currently experiencing an outage.

Replies to support inquiries may be significantly delayed. We appreciate your patience and understanding.
Posted Jan 09, 2026 - 20:44 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Platform).