Consumer Research - Dashboard data is unable to be loaded

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 16:34 UTC

Investigating

We are currently experiencing an issue that is affecting the loading of dashboard data into the platform. Only a small number of Clients are affected by this. Our team is actively investigating the situation to identify the root cause and implement a resolution.

We understand the importance of reliable data access and our Engineering teams are investigating and working to resolve this issue with urgency.

Many thanks for your patience and apologies for any inconvenience caused.

This status page will update as soon as we have further information to share.
Posted Mar 25, 2025 - 11:16 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).