Publish and Engage Module Outage

Incident Report for Brandwatch

Resolved

Our issues with Publish and Engage not working as expected are now resolved. Please reach out to our Support team via the in-app chat or at social-support@brandwatch.com if you are encountering any difficulties.

We thank you for your extended patience and apologise for any frustration caused.
Posted Mar 16, 2023 - 04:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 16:01 UTC

Update

We are continuing to investigate this issue.
Posted Mar 15, 2023 - 15:56 UTC

Investigating

We are currently investigating this issue.
Posted Mar 15, 2023 - 15:37 UTC
This incident affected: Social Media Management (Publish, Engage).