Consumer Research & Listen - Unable to create & edit Queries

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 21:56 UTC

Identified

The issue has been identified. Our Engineering team are investigating causes of instability to the affected services.
Posted Dec 29, 2025 - 08:03 UTC

Investigating

We are currently experiencing an issue where new Queries and Quick Searches cannot be created or edited in our Consumer Research & Listen platforms.
This issue has been escalated to our Engineering Team for further investigation. We sincerely apologise for any inconvenience or disruption this causes.
Posted Dec 29, 2025 - 00:56 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).