Status Update: Owned Facebook and Instagram Data Collection
We're currently unable to collect data from owned Facebook and all Instagram accounts due to a restriction on our business portfolio, which has impacted necessary permissions. This issue has been escalated to our Product Partnership team.
Non-owned and public Facebook data continues to function normally.
Once the restriction is lifted, we may need to complete a verification process to restore access. We’ll provide another update when we have more information.
Thank you for your patience.
Posted Nov 13, 2025 - 10:26 UTC
Investigating
We are currently experiencing an issue affecting our Data Collection service. Users may be unable to reconnect Facebook and Instagram pages.
Our Engineering Team is actively investigating the issue. Preliminary findings suggest the root cause may be related to Meta’s platform. We will provide updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Nov 13, 2025 - 01:55 UTC
This incident affects: Consumer Intelligence (Data Collection).