Consumer Intelligence - Alerts Loading issue

Incident Report for Brandwatch

Resolved

Thank you for your patience. This issue has been resolved.
Posted May 06, 2025 - 19:47 UTC

Investigating

We’re currently investigating an issue affecting Consumer Intelligence, specifically the Custom Alerts feature. Users may encounter a “Server error” message when attempting to view their list of custom alerts.

Our engineering team is actively investigating this with urgency. The issue appears to be intermittent.

Thank you for your patience, and we apologize for the inconvenience.
Posted May 06, 2025 - 18:46 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).