Consumer Research/Listen - Query backfill issues and possible delays in visibility of realtime data

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted May 28, 2026 - 17:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 28, 2026 - 14:40 UTC

Identified

We are currently investigating an issue affecting query backfilling, where some queries are hanging, delayed, or remaining at 0% completion.

This may also affect delays in visibility of realtime data.

Our Engineering team is actively investigating this with urgency, and we will continue to provide updates as we learn more.

Thank you for your patience and understanding.
Posted May 28, 2026 - 13:25 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Listen).