Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2025 - 09:00 UTC
Scheduled
The Influence platform will undergo maintenance with little risk of product disruption on Saturday, 15 November 2025 (09:00–11:00 CET, 03:00–04:00 EDT, 17:00–19:00 AEST).
What’s happening: We’re carrying out planned upgrades to keep the Influence platform running smoothly and reliably.
What this means for you: There is minimal risk of product disruption and no action is needed from your side, you can continue using Influence as normal.
How long will it take: We expect the work to last less than 1 hour, but we’re reserving a 2-hour window to make sure everything runs as expected.
After the work: Our engineering team will be online throughout the process and will keep a close eye on the platform.
Posted Nov 10, 2025 - 16:43 UTC
This scheduled maintenance affected: Influence (Influence Platform).