We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:34 UTC
Update
We have an update on the ongoing Cloudflare situation.
Due to the wider Cloudflare disruption, all Brandwatch platforms are currently impacted. This includes Social Media Management, Consumer Research and Influence. Users may experience difficulty accessing the platform or face intermittent errors.
Our teams are actively monitoring the situation and remain in close contact with Cloudflare while we work toward full restoration.
We will continue to keep this page updated as new information becomes available.
Posted Nov 18, 2025 - 12:34 UTC
Monitoring
We have identified a Cloudflare issue that may impact users from accessing Consumer Research and Listen via signin.brandwatch.com, which produces a 500 Internal Server error if the user is not already logged into the platform.
Our Engineering teams are investigating and working to resolve this issue with urgency.
Many thanks for your patience and apologies for any inconvenience caused.
This status page will update as soon as we have further information to share.
Posted Nov 18, 2025 - 12:11 UTC
This incident affects: Consumer Intelligence (Consumer Research Application), Influence (Influence Platform), and Social Media Management (Platform, Listen).