Engage - Issues with messaging composition functions

Incident Report for Brandwatch

Resolved

Thank you for your continued patience. The issues with Engage have been resolved.
Posted Jul 01, 2026 - 16:58 UTC

Investigating

We identified an issue where the text box for Engage replies is not behaving as expected.

Our team is actively investigating, and we appreciate your patience while we work to resolve it.
Posted Jun 30, 2026 - 22:16 UTC
This incident affected: Social Media Management (Engage).