Consumer Research - Query Backfill delays

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 08:44 UTC

Investigating

We are currently experiencing a delay with Query backfills impacting both Consumer Research & Listen platforms.

This issue has been escalated to our Product Engineers who are investigating the issue.

We apologise for any inconvenience or disruption this causes. We will provide an update as soon as further details are available.
Posted Sep 04, 2026 - 04:40 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Listen).