All Systems Operational

Consumer Intelligence ? Operational
Consumer Research Application Operational
Data Collection Operational
Brandwatch Help Center Operational
Brandwatch Consumer Research API Operational
Brandwatch Data Upload API Operational
Vizia Admin Operational
Vizia Command Center Operational
Brandwatch Reviews Operational
Social Media Management ? Operational
Platform (Falcon) Operational
Publish Operational
Engage Operational
Audience Operational
Advertise Operational
Measure Operational
Benchmark Operational
Listen Operational
Filestack API Operational
Cloud Elements EU Production Operational
Influence (Paladin) Operational
Influence ? Operational
Influence Platform Operational
Discover Operational
Influencer's CRM Operational
Campaigns Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Apr 5, 2025

No incidents reported today.

Apr 4, 2025

No incidents reported.

Apr 3, 2025

No incidents reported.

Apr 2, 2025

No incidents reported.

Apr 1, 2025

No incidents reported.

Mar 31, 2025

No incidents reported.

Mar 30, 2025

No incidents reported.

Mar 29, 2025

No incidents reported.

Mar 28, 2025

No incidents reported.

Mar 27, 2025

No incidents reported.

Mar 26, 2025

No incidents reported.

Mar 25, 2025
Resolved - This incident has been resolved.
Mar 25, 16:34 UTC
Investigating - We are currently experiencing an issue that is affecting the loading of dashboard data into the platform. Only a small number of Clients are affected by this. Our team is actively investigating the situation to identify the root cause and implement a resolution.

We understand the importance of reliable data access and our Engineering teams are investigating and working to resolve this issue with urgency.

Many thanks for your patience and apologies for any inconvenience caused.

This status page will update as soon as we have further information to share.

Mar 25, 11:16 UTC
Mar 24, 2025

No incidents reported.

Mar 23, 2025

No incidents reported.

Mar 22, 2025

No incidents reported.