Consumer Research - Explore mode currently not functioning correctly
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 10:58 UTC
Investigating
Viewing a Query in Explore mode is currently returning no results.

Our Engineers are currently investigating the issue.
Posted Apr 25, 2024 - 10:39 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).