The issue affecting SSO logins has now been fully resolved.
Our team has verified that all systems are operating normally, and access has been restored for all users.
Thank you for your patience while we worked to resolve this issue. If you continue to experience any problems, please contact support.
Posted Mar 25, 2026 - 10:42 UTC
Monitoring
Update: SSO Login Issue
We have implemented a fix for the SSO login issue, and services are now recovering.
Our team is currently monitoring the system to ensure stability and confirm that all functionality is fully restored.
We will provide further updates if any additional issues are identified. Thank you for your patience.
Posted Mar 25, 2026 - 10:10 UTC
Identified
We are currently investigating an issue where some users authenticating via Single Sign-On (SSO) may experience difficulties logging into Brandwatch.
Our team is actively working to identify the root cause and restore normal service as quickly as possible. We will provide further updates as soon as more information becomes available.
Thank you for your patience.
Posted Mar 25, 2026 - 09:28 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).