Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 19, 2025 - 06:00 UTC
Scheduled
We will be performing an infrastructure upgrade on Sunday 19th October, for Engage - Social Media Management.
Maintenance Window: Sunday 19th October 7:00–8:00 AM BST, 8:00–9:00 AM CET, 2:00–3:00 AM ET, 4:00–5:00 PM AEST. We’re allocating 1 hour window to ensure a smooth rollout, though maintenance may complete earlier than scheduled.
What to Expect: During this time, Engage will be completely unavailable. Users accessing the module will see a maintenance message.
No data loss is expected. Once the maintenance is complete, all messages from this period will appear in Engage as usual.
Our Product, Engineering, and Support teams will be actively monitoring the maintenance and ready to respond to any issues.
We appreciate your patience and understanding as we continue to improve our platform to serve you better.
Posted Oct 13, 2025 - 11:55 UTC
This scheduled maintenance affected: Social Media Management (Engage).