Measure: Dashboards Not Loading

Incident Report for Brandwatch

Resolved

The issue affecting the availability of Measure dashboards has now been resolved and dashboards are loading and operating as expected.

Our teams have confirmed that normal functionality has been restored. We will continue to monitor the service to ensure stability.

We apologise for the disruption and thank you for your patience while we worked to resolve the issue.
Posted Aug 19, 2026 - 21:31 UTC

Investigating

We are currently investigating an issue affecting dashboard availability, where some users may experience dashboards failing to load or being unable to access dashboard content as expected.

Our Engineering teams are investigating the issue to identify the underlying cause and restore normal functionality. We are treating this as a priority and are working to minimise disruption for affected users.

We apologise for the inconvenience this may cause and appreciate your patience while we work to resolve the issue. We will provide further updates as our investigation progresses.
Posted Aug 19, 2026 - 19:39 UTC
This incident affected: Social Media Management (Measure).