Consumer Research - Query Backfill Delays

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 16:07 UTC

Investigating

We're currently experiencing a delay with query backfills, and our Engineering team is investigating the cause.
Posted Sep 03, 2026 - 15:21 UTC
This incident affected: Consumer Intelligence (Consumer Research Application) and Social Media Management (Listen).