Consumer Research - Mention Processing

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 15:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 03, 2025 - 07:56 UTC

Identified

We are currently experiencing delays in mention metrics processing across the platform. This began following the recent outage and has resulted in a backlog that is still being worked through.

Processing has resumed and we are seeing ongoing progress. Our engineering team is also assessing options to safely increase processing capacity while monitoring downstream systems.

This affects mention metrics generated within the past 24 hours. Backfilled data remains accurate.
Posted Dec 03, 2025 - 00:23 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Listen).